I'm having trouble installing the Twinkl App

The Apple App Store won't let me download the app

The Twinkl app needs iOS 9 or above to run. To upgrade your phone to the latest version of iOS, open the Settings app -> General -> Software Update. The iPhone will look for the latest version of iOS and install it for you. Make sure you backup your phone first!

The App won't open on my phone?

First try closing the app fully. Do this by double tapping the home button, searching for the Twinkl app and swiping up. Try to relaunch the app and hopefully all will be fixed. If this does not fix the issue, then you can uninstall and reinstall the app. If you are still having issues after this, please let us know!


« Back to Technical

Careers